Tuesday , July 23 2019
Home / BackTrack / Fix BackTrack Error / Msfupdate svn certificate errors

Msfupdate svn certificate errors

Desc

BackTrack Version : BackTrack 5
Error type: Software, Application, metasploit, msf3

Error Message

[text]"svn: E175002: Unable to connect to a repository at URL ‘https://www.metasploit.com/svn/framework3/trunk’ "
"svn: E175002: OPTIONS of ‘https://www.metasploit.com/svn/framework3/trunk’: Server certificate verification failed: issuer is not trusted (https://www.metasploit.com) " [/text]

Fix Step:

[sociallocker]

Edit msfupdate

[text][email protected]:~#gedit /opt/metasploit/msf3/msfupdate[/text]

tambahi code di bawah ini

[text]@args.push("–trust-server-cert")

end

@args.delete_at @wait_index if @wait_index
@args.delete_at @configdir_index if @configdir_index

@args.push("–non-interactive")
@args.push("–config-dir=#{@configdir}") if @configdir_index
@args.push("–trust-server-cert")

res = system("svn", "cleanup")
if res.nil?[/text]

save and testing

[text][email protected]:~#msfupdate
[*] [*] Attempting to update the Metasploit Framework…
[*]

Updating ‘.’:
At revision 15991.[/text] [/sociallocker]

Refrence :

$forum/Thread-FIXED-msfupdate-yang-muncul-svn-certificate-errors