[FIX] Failed [msfupdate] data/svn
#1
Maaf klo repost ya..!!!
Saya mengalami masalah ketika mengupdate msfconsole, pesan failnya sprti ini :

[email protected]:~# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]

svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: Failed to add directory 'data/svn': an unversioned directory of the same name already exists..!!!

HeLp..!!!

#2
coba locate data/svn kemudian hapus filenya

atau bisa ga ya msfupdate --force ?

#3
Oke, td sebelum ngefix sy smpat minta bantuan di forum ini karna alamin sedikit masalah dengan metasploit update (http://forum.indonesianbacktrack.or.id/s...p?tid=1729) !

[email protected]:~# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]

svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: Failed to add directory 'data/svn': an unversioned directory of the same name already exists..!!!

Perhatikan baris yang tebal, sy kira masalah ini belum di bahas sebelumnya atau mungkin sudah tp sy yg gak muter di room..!!!

Jika nnti kawan2 dapat masalah seperti ini, mungkin dengan cara berikut akan membantu.

FIX :
Pesan seperti ini : svn: Failed to add directory 'data/svn': an unversioned directory of the same name already exists..!!!, berarti folder "svn" di situ sudah ada pada locate "/pentes/exploits/frameworks3/" jadi tadi saya hapus folder "svn"nya kemudian saya mengetik di console sprti ini :
[email protected]:/pentest/exploits/framework3# svn up

More : http://www.backtrack-linux.org/forums/sh...hp?t=40386

dan berhasil!
Like this :
[email protected]:~#/pentest/exploits/framework3# svn up
At revision 12590.
[email protected]:~#/pentest/exploits/framework3# msfupdate[*][*] Attempting to update the Metasploit Framework...[*]

svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)

Metasploit sy dh ke'update..!!!
Smga membantu..!!!


#4
ane merge threadnya biar lebih rapi
thx bro +1 dari ane

#5
Ooh .. oke gak, apa maaf sy baru di forum onlen Big Grin .. Thanks
Td sy gak bisa bales di sini kawan, ada pesan alert dri browser, sorry .. !!!
Smile

#6
(01-30-2012, 01:02 AM)geeky Wrote: Ooh .. oke gak, apa maaf sy baru di forum onlen Big Grin .. Thanks
Td sy gak bisa bales di sini kawan, ada pesan alert dri browser, sorry .. !!!
Smile


hehe gapapa om,selamat bergabung Big Grin terus share ya om jika ada masalah tentang backtrack di mari Big Grin semoga Tread ini bisa membantu kawan-kawan yang mengalami hal sama ketika mengupdate metasploit Angel Smile


#7
yarp .. Smile






Users browsing this thread: 1 Guest(s)